TES Reloaded
Would you like to react to this message? Create an account in a few clicks or log in to continue.
TES Reloaded
TES Reloaded is one of the biggest project of the modding community.
It is a plugin for Oblivion, Skyrim and Fallout New Vegas.

HAVE FUN!
AlenetAdministrator
The Author
GBRModerator
lldeModerator
malonnModerator

Timeslip


Oblivion Graphics Extender (OBGE) v1.0

Scanti


Oblivion Graphics Extender (OBGE) v2.0

ShadeMe


Oblivion Graphics Extender (OBGE) v2.0

Ethatron


Oblivion Graphics Extender (OBGE) v3.0
avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 10:10
Hello all,

I've been trying to get OR running for two days now and I'm reaching the end of my rope a bit. I'll recount the exact process that led me to this point real quick:

Upon finding out that OBGE was deprecated when searching for a new version I correctly uninstalled it and found OR. I downloaded and followed the instructions exactly in terms of manual installation - though it was mid game. After that I started up the game and loaded the save clean from OBGE however it got about 3/4 of the way through loading before crashing with a .dmp file.

The OR.dll is the problem, I'm not sure why. But renaming it to OR.dll.noload always works and I can load the game with no issues and play it with no issues. Only with the .dll enabled does the game crash on loading a save. At this point I have gone into the .ini and disabled every feature for OR and it still crashes. I'm not sure what I'm doing or have done wrong, but would love some help. Below are some posted logs - if those are a help to anyone.

NVAC Log:
01221507 _ NewVegasAntiCrash Oblivion.exe
01221507 _ 04510000 07050000 nvac.dll
01221507 _ 5F7B0000 00000015 obse_1_2_416.dll
01221507 _ 774F0000 0A0047BB ntdll.dll
01221643 u F7E1B2F0 C0000005

I know C0000005 is an exception access violation for Windows and F7E1B2F0 is always the memory address where it crashes, but I can't do much with that.


OR Log (No errors or anything, just a bunch of textures and shaders loaded, but these are the last few lines):
Shader loaded: Data\Shaders\OblivionReloaded\Water\WATERDISPLACE004.pso
Shader loaded: Data\Shaders\OblivionReloaded\Water\WATERDISPLACE005.vso
Texture linked: Data\Textures\Water\water_NRM.dds
Shader loaded: Data\Shaders\OblivionReloaded\Water\WATERDISPLACE005.pso
Shader loaded: Data\Shaders\OblivionReloaded\Water\WATERDISPLACE006.vso
Shader loaded: Data\Shaders\OblivionReloaded\Water\WATERDISPLACE006.pso


OBSE Log (again, no errors - these are the last few lines):
loading from C:\Users\XXX\Documents\My Games\Oblivion\Saves\Save 430 - Lyana - Lyra Rosentia's House, Level 3, Playing Time 12.20.23.obse
Reading mod list from co-save
Loading strings
Loading array variables
DoLoadGameHook: C:\Users\XXX\Documents\My Games\Oblivion\Saves\Save 430 - Lyana - Lyra Rosentia's House, Level 3, Playing Time 12.20.23.ess
loading from C:\Users\XXX\Documents\My Games\Oblivion\Saves\Save 430 - Lyana - Lyra Rosentia's House, Level 3, Playing Time 12.20.23.obse
Reading globals

I'm working on setting up an environment that can decipher the .dmp file now, so I'll post that when I'm ready. Any help in the meantime would be hugely appreciated.
avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 11:40
Alright, I've got WinDbg.exe working and analyzing OBSE's .dmp file, here we go (going to try and break apart key points, but it's hard to tell what's important):

ExceptionAddress: f7e1b2f0
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 00000000
Parameter[1]: f7e1b2f0
Attempt to read from address f7e1b2f0

PROCESS_NAME: Oblivion.exe

READ_ADDRESS: f7e1b2f0

FAILED_INSTRUCTION_ADDRESS:
+0
f7e1b2f0 ?? ???

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.


So it seems like the error is occurring with Oblivion.exe itself with the OR.dll enabled rather than the OR.dll conflicting with another .dll. Makes sense, I disabled practically everything and it was still breaking.

IP_ON_HEAP: f7e1b2f0
The fault address in not in any loaded module, please check your build's rebase
log at \bin\build_logs\timebuild\ntrebase.log for module which may
contain the address if it were loaded.


Will report back on these lines later. Gonna launch and crash Oblivion again then check the log to see if I can find the memory address. Something else that's appearing a lot is an ntdll which is a .dll file I'm unfamiliar with. Thought it may have been the Oblivion_Display_Tweaks.dll but I got that name wrong. Guess I'm still thinking of New Vegas Tick Fix.

SYMBOL_NAME: oblivion+d420

MODULE_NAME: Oblivion

IMAGE_NAME: Oblivion.exe

STACK_COMMAND: ~0s ; .ecxr ; kb

FAILURE_BUCKET_ID: BAD_INSTRUCTION_PTR_c0000005_Oblivion.exe!Unknown

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release

OSPLATFORM_TYPE: x86

OSNAME: Windows 10

FAILURE_ID_HASH: {9a92b3c1-d200-5afd-d1fe-9fe84478bcb1}

Followup: MachineOwner



The final lines of the debugger's .dmp file analysis. I'll try to do some research on what exactly this is telling me, but if anyone knows already feel free to comment - I'd love to hear it. The gist of it seems to be that Oblivion itself is failing somehow with OR.dll enabled. Maybe there's a setting I'm missing or the Oblivion.ini file is incompatible somehow due to a certain setting. I did use BethINI on it before installing OR, so that could be a problem.

Will keep this thread updated in case anyone else runs into a similar problem sometime in the future.


Defirdayon
Defirdayon
Posts : 37
Join date : 2020-09-14

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 14:09
What happens, if you start a new game, make a new save and try to load it?

Did you make sure that all files from previous OBGE are completely de-installed? - Maybe, there's something left interfering (maybe a shader).

Sometimes it helps to delete the old Oblivion.ini. OR sets at its first start a couple of values to the ini. If Oblivion.ini is write-protected, OR can't do that and problems occur. Just a guess.

The other mentioned plugins (OBSE, Oblivion Display Tweaks, NVAC) shouldn't cause problems (I use them too without problems along OR).
avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 14:32
Same thing happens on trying to start a new game as trying to load an old one: it gets some amount through the loading bar (no more than 3/4ths) and then crashes with an OBSE .dmp file. The only difference is it loads the new game intro movie just fine - the game only crashes upon attempting to actually load into a cell or area.

I'll triple check that OBGE is completely uninstalled but I'm almost certain it is. As for deleting the .ini I will try that and get back to you
avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 14:47
@Defirdayon wrote:What happens, if you start a new game, make a new save and try to load it?

Did you make sure that all files from previous OBGE are completely de-installed? - Maybe, there's something left interfering (maybe a shader).

Sometimes it helps to delete the old Oblivion.ini. OR sets at its first start a couple of values to the ini. If Oblivion.ini is write-protected, OR can't do that and problems occur. Just a guess.

The other mentioned plugins (OBSE, Oblivion Display Tweaks, NVAC) shouldn't cause problems (I use them too without problems along OR).

Alright, just got out of testing. OBGE is definitely fully uninstalled and I've even got the original 1.2.0416 shaders for Oblivion installed that I got off the nexus. Removing the Oblivion.ini and letting the game make a new one didn't work either - same crash. Same error.

It seems like, somehow, the OR.dll is instructing the Oblivion.exe to handle memory either unavailable to it or not created yet. Based off the .dmp file at least. I've been looking all over the internet for other programs that exit, make a .dmp file, and contain a similar error to BAD_INSTRUCTION_PTR_c0000005, but there's not much out there
Defirdayon
Defirdayon
Posts : 37
Join date : 2020-09-14

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 16:05
That's weird. There are some additional testing possibilities:

1.) I assume, that the main menu works and you can get into it. Do you see OR's version number in main menu? - If yes, OR basically works.
2.) Did you try to disable the several features in OblivionReloaded.ini? - Especially Equipment mode has yet some issues. I would try to disable the features in groups (beginning with gameplay features as Equipment mode, mounted combat etc. then taking a look on shaders and effects).
3.) Re-booting your machine (no joke) sometimes helps too with left-overs in Memory.
4.) Is it a Vanilla install or already modded with HiRes-textures (therefore OR's memory management should be enabled and I assume LAA-patch is also applied)? Maybe there's a mod or a function interfering. Especially ENB isn't compatible out of the box.

avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 16:20
@Defirdayon wrote:That's weird. There are some additional testing possibilities:

1.) I assume, that the main menu works and you can get into it. Do you see OR's version number in main menu? - If yes, OR basically works.
2.) Did you try to disable the several features in OblivionReloaded.ini? - Especially Equipment mode has yet some issues. I would try to disable the features in groups (beginning with gameplay features as Equipment mode, mounted combat etc. then taking a look on shaders and effects).
3.) Re-booting your machine (no joke) sometimes helps too with left-overs in Memory.
4.) Is it a Vanilla install or already modded with HiRes-textures (therefore OR's memory management should be enabled and I assume LAA-patch is also applied)? Maybe there's a mod or a function interfering. Especially ENB isn't compatible out of the box.


1.) I have no trouble getting to the main menu and I do see OR's version number there, yeah. Only when the .dll is loaded of course
2.) I've disabled every feature in the OR.ini save for keycodes as I'm not entirely sure of the given disabled values for that section. It could be a conflict since I do also have AIStewie's tweaks.dll loaded and he has a WASD_for_menus option in his ini.
3.) Saw that mentioned and have tried it a few times since install. Doesn't seem to have any effect or change anything unfortunately
4.) It's an already modded setup, yeah. The LAA patch is enabled and I have also enabled OR's Memory_Management to no effect. I did have enb binaries installed as part of OBGE and my old setup, but I uninstalled everything it placed - inclduing the d3d9.dll

Update: it wasn't the keys either

Outside of decompiling the OR.dll and trying to manually trace the error stack to find the exact line/function that's calling this invalid memory I'm somewhat out of ideas to be honest
Defirdayon
Defirdayon
Posts : 37
Join date : 2020-09-14

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 17:00
So it could be everything. In most cases it is only a misplaced/not-installed/mis-seen file or something like that. As your description shows, everything is running: OBSE, OR, the game starts, the menu appears - all until it comes to a cell load.

So as a last guess into the blue (even it is a little bit far-fetched): Isn't OBGE not doing something with Lod's (introducing its LLOD-System if I remember correctly). Perhabs that's the culprit. This wouldn't explain a crash loading the starter (interior) cell, but broken LOD's could crash the loading of exterior cells. I had such cases, where the loading bar (while loading the savegame) went as you described and then crashes - sure only for exteriors, but almost ever LOD related.

Maybe some others here will also have some additional ideas about your issue. If you find, what causes the crash, it would be interesting to hear about it.
avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Tue 02 Feb 2021, 17:31
It seems that way doesn't it? I appreciate your help through this, I'll keep at it and report back if I figure out the issue. I used TES4LODGen a while back but deleted the LODs before installing OR. I'll try remaking them and see if that does anything
avatar
Visas
Posts : 2
Join date : 2021-03-17

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Wed 17 Mar 2021, 14:03
Hey, just to chime in, i'm someone with the same issue, with loading saves and creating new games (past the Patrick Stewart intro) crashing the game. Have also gone through the same possible fixes, and disabling the .dll allows for normal loading.

This issue might have been introduced in a recent version of OR. I couldn't find releases older than 8.0 for the main mod, but Oblivion Reloaded Lite version 3.7 seems to work fine for me. Maybe AFiddlingSnail can confirm?
avatar
AFiddlingSnail
Posts : 7
Join date : 2021-02-02

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Sat 20 Mar 2021, 12:07
Hey, yeah! Downloaded an older lite version and it seems to be working alright. I also found the OR Lite/Refactored on Nexus that also uses the 8.3.dll and it always crashes as well. It's definitely something that got introduced in 8.3 or maybe even a version earlier.

I've just not been able to play with the 8.3 .dll loaded. Shame, because I was really looking forward to it.

Not sure if this helps but I'm using an AMD card - I've seen some stuff that makes me think OR doesn't play nice with their equipment
malonn
malonn
Posts : 127
Join date : 2020-09-14
Location : Ohio, U.S.A.

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Sat 20 Mar 2021, 13:13
Confirmed, right now. OR on AMD is buggy as hell. The developer does not own (nor will he, probably) AMD and can't troubleshoot the issues. It's their drivers. They are different than Nvidia's. Maybe one day someone will gift him an AMD card, and if he has time he might work with it. I don't know. Alenet is busy. He spends plenty of time with the TES Reloaded mods, but he owns a company, has a family, etc.
avatar
Visas
Posts : 2
Join date : 2021-03-17

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Sun 21 Mar 2021, 06:32
I don't think it's a hardware thing. I've got an nvidia 1060 GPU myself, along with other pretty popular components.
I'll report here if i ever figure out what's causing the crashes
malonn
malonn
Posts : 127
Join date : 2020-09-14
Location : Ohio, U.S.A.

8.3 Crashing on Save Load/New Game Empty Re: 8.3 Crashing on Save Load/New Game

Mon 22 Mar 2021, 19:48
@Visas wrote:I don't think it's a hardware thing. I've got an nvidia 1060 GPU myself, along with other pretty popular components.
I'll report here if i ever figure out what's causing the crashes
Sorry, I was responding the the post above my post (I don't feel like diddling with this damn forum software right now to post his/her name). There sure are several things that I don't like about this forum software.
Permissions in this forum:
You cannot reply to topics in this forum